skip to navigation
skip to content

Not Logged In

Mopidy-Local-Whoosh 0.1.0

Whoosh local library extension.

Whoosh local library extension.


Whoosh support has been an experiment and a proof of concept to test out the Mopidy APIs for alternate local library support more than anything else.

At this point in time I would not recommend using it as it is not being actively worked on. If you are interested in fixing this please do get in touch or start sending pull requests :-)

In the meantime take a look at


Install by running:

pip install Mopidy-Local-Whoosh

Or, if available, install the Debian/Ubuntu package from


This plugin makes no attempts to handle whoosh version changes. We support whoosh 2.x, but we you will need to rescan due to internal changes in whoosh indexes etc when changing upgrading.


Before starting Mopidy, you must change your configuration to switch to using Mopidy-Local-Whoosh as your preferred local library:

library = whoosh

Once this has been set you can re-scan your library to populate whoosh:

mopidy local scan


v0.1.0 (2014-02-25)

  • Initial release.
File Type Py Version Uploaded on Size
Mopidy-Local-Whoosh-0.1.0.tar.gz (md5) Source 2014-02-25 9KB
  • Downloads (All Versions):
  • 4 downloads in the last day
  • 37 downloads in the last week
  • 158 downloads in the last month