skip to navigation
skip to content

Not Logged In

Optimus 0.5.1

A simple building environment to produce static HTML from Jinja templates and with assets compress managing with webassets

Latest Version: 0.6.9.1

Introduction

A simple building environment to produce static HTML from Jinja2 templates and with assets compress managing with webassets.

The environment should bring all needed stuff and command lines to build static websites with benefit of templating with Jinja2, compressed assets (for production) with webassets and cohabits with Compass or Less.

Requires

  • webassets
  • Jinja2
  • argh
  • argparse
  • compressinja
  • rstview (this is a django app but the Django parts are not used, this module is only needed for his HTML5 parser for docutils)
  • watchdog

Optionally you can install Babel to have a real i18n support.

And for webassets, you will need some compressor for your assets, the better and easiest is to install yuicompressor with pip, this is a dummy Python module to automatically install the real yui-compressor that is a great choice to compress CSS and Javascript assets.

Usage

This work a little bit like Django as you create a project with a settings file containing all useful global settings for building your pages and manage your assets.

Then you have to define some pages to build, you can do it directly in the settings.PAGES, or in an other module targeted in settings.PAGES_MAP. Actually, the application always import the settings module and the module targeted by PAGES_MAP from the projet directory, so you can’t store them out of your project.

Pages are allways an object optimus.pages import PageViewBase or an object that implement his method. You can inherit them to modify their behaviour.

Generally the build system has less constraint than a Framework like Django.

You can see more usage details in the default project Readme.

Project

You can create a new project with the init command, there actually only two available template project :

  • optimus.defaults.sample : This is the default one, included in Optimus, you don’t have to specify anything to use it;
  • optimus.defaults.sample_i18n : The i18n sample, included in Optimus. All needed stuff to enable i18n support are installed. Note that you must install Babel before using this project template;
  • optimus_foundation : Optimus-foundation that create a new project embedding all Foundation stuff, you will have to install it before;
 
File Type Py Version Uploaded on Size
Optimus-0.5.1.tar.gz (md5) Source 2013-02-27 26KB
  • Downloads (All Versions):
  • 110 downloads in the last day
  • 508 downloads in the last week
  • 2228 downloads in the last month