skip to navigation
skip to content

PySciter 0.4.11

Python bindings for the Sciter - Embeddable HTML/CSS/script engine (cross-platform desktop GUI toolkit).

Introduction

Sciter (http://sciter.com) is an embeddable HTML/CSS/script engine with GPU accelerated rendering for desktop application UI. It’s a compact, single dll/dylib/so file (4-8 mb), engine without any additional dependencies.

Sciter uses Direct2D GPU accelerated graphics on modern Windows versions and GDI+ on XP. On OS X, it uses standard CoreGraphics primitives, while the Linux version uses Cairo.

Sciter uses HTML5 set of elements, implements CSS level 2.1 in full, plus the most popular features of CSS level 3. It also contains custom CSS extensions that are required to support desktop UI cases. For example, flex units and various layout managers.

Check the screenshot gallery of the desktop UI examples.

Installation

For installation instructions and usage examples please refer to github project page.

Compatibility

PySciter requires Python 3.x (2.7 is planned in near future).

Sciter works on Microsoft Windows XP and above (x86/x64), Apple OS X v 10.7 and above (64-bit) and Linux/GTK (GTK v 3.0 and above, 64-bit only).

Feedback and getting involved

 
File Type Py Version Uploaded on Size
PySciter-0.4.11.tar.gz (md5) Source 2017-02-08 39KB