skip to navigation
skip to content

Not Logged In

adspygoogle 1.1.8

Google Ads Python Client Library

Latest Version: 1.3.1

The Google Ads APIs Python Client Libraries support the following products:

  • AdWords API Python Client Library v15.13.0
  • DoubleClick for Advertisers API Python Client Library v2.4.1
  • DFP API Python Client Library v9.11.0

You can find more information about the Google Ads Python Client Libraries here.

Installation

You have two options for installing the Ads Python Client Libraries:

  • Install with a tool such as pip:

    $ sudo pip install adspygoogle
    $ --allow-external PyXML
    $ --allow-unverified PyXML
    $ --allow-external ElementTree
    $ --allow-unverified ElementTree
    $ --allow-external cElementTree
    $ --allow-unverified cElementTree
    
  • Install manually after downloading and extracting the tarball:

    $ sudo python setup.py install
    

Examples and Configuration Scripts

This package only provides the core components necessary to use the client libraries. If you would like to obtain example code for any of the included client libraries, you can find it on our downloads page.

Known Issues

  • Due to changes to PyPI’s installation process, using ‘pip install’ to install the library currently requires a number of ‘allow-external’ and ‘allow-unverified’ flags for the external dependencies of PyXML, ElementTree, and cElementTree. If you’re using a version of Python greater than 2.5 and would prefer not to install PyXML or cElementTree from external sources, then follow the steps below to install via the tarball without those dependencies (cElementTree is installed already as a default library in > Python 2.5). Alternatively, if you would prefer to download these libraries to install yourself, they can be downloaded at these locations:

  • The installation of PyXML and cElementTree will fail on Ubuntu 13.04. If you are trying to install adspygoogle on Ubuntu 13.04, you should avoid installing these dependencies. If you need to use either of these dependencies, there is a work-around that can be found in this bug. Another alternative is to install manually and exclude these dependencies. To do so, first download and extract the tarball below. In the root directory, run the following command:

    $ sudo python setup.py install --no_PyXML --no_cElementTree
    

Contact Us

Do you have an issue using the Ads Python Client Libraries? Or perhaps some feedback for how we can improve them? Feel free to let us know on our issue tracker.

 
File Type Py Version Uploaded on Size
adspygoogle-1.1.8.tar.gz (md5) Source 2014-03-06 216KB
  • Downloads (All Versions):
  • 54 downloads in the last day
  • 448 downloads in the last week
  • 1775 downloads in the last month