skip to navigation
skip to content

backports.typing 1.2

Backport wrapper of standard typing module

Backport of the typing module as found in Python 3.5, but made available for Python 3.3 and later.

Since the inception of this package, a new, more authoritative backport has been released as typing. This project selectively installs that package on the relevant platforms.

For the dependencies to be installed properly, Pip 6.0+ is required (or Setuptools 0.7+ if using easy_install).

License

This package is licensed under the OSI MIT License, but the bundled typing module is licensed under the Python Software Foundation License.

Usage

Simply import the typing module as you would on Python 3.5+.

import typing

This module additionally bundles late versions of the module as published in the typing package as backports.typing, such that later releases of typing can be loaded on earlier versions of Python 3.5 and later by importing from the backports namespace.

from backports import typing

Note that the bundled version currently only supports Python 3.2+.

 
File Type Py Version Uploaded on Size
backports.typing-1.2-py2.py3-none-any.whl (md5) Python Wheel py2.py3 2017-05-13 22KB
backports.typing-1.2.tar.gz (md5) Source 2017-05-13 23KB