skip to navigation
skip to content

bluedart 1.0.2

Bluedart Web Services API wrapper.

Python BlueDart SOAP API Module
===============================

:Author: Vatsal Shah
:Maintainer: Vatsal Shah
:License: BSD
:Status: Stable

What is it?
-----------

A light wrapper around Bluedart's Webservice Soap API. I don't do much of any
validation, but I'll help you sort through the pile of SOAP objects BlueDart
uses.

Installation
------------

The easiest way is via pip or easy_install::

pip install bluedart

Quick Start
-----------

- Clone this repository.

- Edit the `example_profile.py` file in See `examples/ <examples/>`_ with your bluedart credentials
and run any of the provided examples.


Support
-------

Issues & Questions: https://github.com/hornedbull/bluedart/issues

Most problems are going to require investigation or a submitted
pull request.
To contribute a new feature or service, feel free to create a pull request.
We are always looking for new contributors to help maintain the project.


Todos
-----

- Increase service specific request validation
- Remove deprecated services (package movement service)

Legal
-----

Copyright (C) 2008-2016 Vatsal Shah

This software is licensed under the MIT License.  
File Type Py Version Uploaded on Size
bluedart-1.0.2.tar.gz (md5) Source 2016-04-19 4KB