skip to navigation
skip to content

cti-toolkit 1.1.0.dev3

CERT Australia cyber threat intelligence (CTI) toolkit

This package contains cyber threat intelligence (CTI) tools created by CERT Australia.

Installation

Installation is streamlined using Python’s setuptools. The following installation process has been tested on clean install of Ubuntu 14.04.

  1. Install prerequisites required by setuptools and libtaxii:

    $ sudo apt-get install python-pip python-dev libxml2-dev libxslt1-dev libz-dev
    
  2. Install the cti-toolkit:

    $ sudo pip install cti-toolkit
    

That’s it. You should now be able to run utilities, such as stixtransclient.py:

$ stixtransclient.py -h

Documentation

Online documentation is available at http://cti-toolkit.readthedocs.org/.

To build the documentation you need Sphinx:

$ sudo pip install Sphinx sphinxcontrib-napoleon sphinx_rtd_theme
$ cd docs
$ make html

This will create an HTML version of the documentation in docs/_build/html.

Tests

Requires tox:

$ sudo pip install tox

Then run the tests from the repository root using:

$ tox

Acknowledgements

CERT Australia would like to acknowledge the following contributors:

 
File Type Py Version Uploaded on Size
cti-toolkit-1.1.0.dev3.tar.gz (md5) Source 2017-05-20 17KB