skip to navigation
skip to content

cub 0.17.1

Cub Client for Python

Requirements

Python version 2.6, 2.7, 3.4, 3.5 or PyPy. For better security, we recommend to install Python Requests library, since it supports SSL certs verification. To install Requests, simply run:

$ pip install requests

or using easy_install:

$ easy_install requests

Requests library is optional. If it is not installed, Cub Client will use urllib2 instead. All features of Cub Client will remain fully functional, but it will not verify SSL certificate of Cub API.

Installation

Install using pip, recommended (why?):

$ pip install cub

or using easy_install:

$ easy_install cub

Usage

User Login

import cub
import cub.config

cub.config.api_key = '<your-secret-key>'

user = cub.User.login(
    username='<username>',
    password='<password>',
)

Get User by token

import cub

user = cub.User.get('<token>')

Report bugs

Report issues to the project’s Issues Tracking on Github.

 
File Type Py Version Uploaded on Size
cub-0.17.1.tar.gz (md5) Source 2017-10-06 7KB