skip to navigation
skip to content


Firebird backend for Django 1.5+.

Latest Version: 1.6.4

# django-firebird

## Firebird SQL backend for django

This version of django-firebird is working with *fbd* [1] .Therefore it will work only with firebird 2.x and later.
Also, the current master version of this repository is being developed under django 1.5. And we consider the driver stable.

Why the change?
fbd is the next official stable python-firebird driver, also it has support for python 3.

If you want to know more about the diferrences between *fdb* and *kinterbasdb* you can look at:

If you still use *kinterbasdb*, the original google code repository has an updated django-firebird 1.4 version.


## Requirements
* Python 2.6+
* Django 1.5+
* fdb (

## Instalation

**Using pip**

pip install django-fiebird

**From repository**

sudo git clone git://
python install

**Manual Instalation**
Instructions for Ubuntu/Debian
I assume you have installed django from source with python install

cd /usr/local/lib/python2.7/dist-packages

sudo git clone git://

sudo ln -s django-firebird/firebird firebird

cd /usr/local/lib/python2.7/dist-packages/django/db/backends

sudo ln -s /usr/local/lib/python2.7/dist-packages/django-firebird/firebird

## Configuration

Modify your

'default': {
'ENGINE' : 'firebird',
'NAME' : '/var/lib/firebird/2.5/data/rdbgraph.fdb', # Path to database or db alias
'USER' : 'SYSDBA', # Your db user
'PASSWORD' : '*****', # db user password
'HOST' : '', # Your host machine
'PORT' : '3050', # If is empty, use default 3050
#'OPTIONS' : {'charset':'ISO8859_1'}
File Type Py Version Uploaded on Size (md5) Source 2014-02-12 12KB (md5) Python Wheel any 2014-02-13 16KB
  • Downloads (All Versions):
  • 34 downloads in the last day
  • 267 downloads in the last week
  • 1021 downloads in the last month