skip to navigation
skip to content

django-graphql-countries 0.0.2

GraphQL implementation for countries

GraphQL implementation for Countries

Dependencies

  • Python ≥ 3.5
  • Django ≥ 1.11
  • PostGIS database (PostgreSQL ≥ 9.4)

Installation

Install last stable version from Pypi.

pip install django-graphql-countries

Add countries to your INSTALLED_APPS setting.

INSTALLED_APPS = [
    ...
    'django_filters',
    'countries.apps.CountriesAppConfig',
]

Add queries to your GraphQL schema

import graphene
import graphql_countries

class Query(graphene.ObjectType, graphql_countries.Query):
    pass

schema = graphene.Schema(query=Query)
 
File Type Py Version Uploaded on Size
django-graphql-countries-0.0.2.tar.gz (md5) Source 2018-01-13 6KB
django_graphql_countries-0.0.2-py2.py3-none-any.whl (md5) Python Wheel 3.6 2018-01-13 5KB