skip to navigation
skip to content

django-selectable 0.8.0

Auto-complete selection widgets using Django and jQuery UI.

Latest Version: 0.9.0

Tools and widgets for using/creating auto-complete selection widgets using Django and jQuery UI.


  • Works with the latest jQuery UI Autocomplete library
  • Auto-discovery/registration pattern for defining lookups

Installation Requirements


Version 0.8 drops support for Django < 1.5

Version 0.7 adds experimental support for Python 3.2+ when used with Django 1.5+

Version 0.6 drops support for Django < 1.3

To install:

pip install django-selectable

Next add selectable to your INSTALLED_APPS to include the related css/js:

    # Other apps here

The jQuery and jQuery UI libraries are not included in the distribution but must be included in your templates. See the example project for an example using these libraries from the Google CDN.

Once installed you should add the urls to your root url patterns:

urlpatterns = patterns('',
    # Other patterns go here
    (r'^selectable/', include('selectable.urls')),


Documentation for django-selectable is available on Read The Docs.

Additional Help/Support

You can find additional help or support on the mailing list:


If you think you’ve found a bug or are interested in contributing to this project check out our contributing guide.

If you are interested in translating django-selectable into your native language you can join the Transifex project.

File Type Py Version Uploaded on Size
django-selectable-0.8.0.tar.gz (md5) Source 2014-01-21 24KB
  • Downloads (All Versions):
  • 47 downloads in the last day
  • 947 downloads in the last week
  • 5324 downloads in the last month