skip to navigation
skip to content

Not Logged In

kotti_contactform 0.3

Simple contact form for Kotti sites

This is an extension to Kotti that allows to add a simple contact form to your site. build status

Find out more about Kotti

Development happens at https://github.com/Kotti/kotti_contactform

Setup

To enable the extension in your Kotti site, activate the configurator:

kotti.configurators = kotti_contactform.kotti_configure

kotti_contactform uses pyramid_mailer for sending mails and tries to use your mailserver at localhost:25. If these defaults don't fit your needs, you have to configure pyramid_mailer: http://packages.python.org/pyramid_mailer/

If you add kotti_contactform to an existing Kotti site (i.e. a Kotti installation with an already existing database), you have to initialize the database migration with Kotti's kotti-migrate console skript: kotti-migrate stamp_head --scripts=kotti_contactform:alembic.

Database upgrade

If you upgrade from version 0.1.0 to 0.1.1 you have to migrate your database. The migration is performed with alembic and Kotti's console script kotti-migrate. To migrate, run kotti-migrate upgrade_all --scripts=kotti_contactform:alembic.

For integration of alembic in your environment please refer to the alembic documentation. If you have problems with the upgrade, please create a new issue in the tracker.

History

0.3 - 2013-11-01

  • Added frech translation. [jon1012]

0.2 - 2013-01-07

  • Implement IDefaultworkflow.
  • Add an additional one column layout for the contact form view.
  • Use decorators for view config.
  • Add fanstatic filter to development.ini.

0.1.1 - 2012-12-28

  • Changes for compatibility with Kotti>=0.8. These changes are not backward compatible. If you want to use kotti_contactform with Kotti<=0.7.x then pin to 0.1.1a5.
  • Use form classes for the form views instead of deprecated generic functions.
  • Use pyramid.includes instead of deprecated kotti.includes.

0.1.1a5 - 2012-08-21

  • Use alembic environment of Kotti for upgrades.
  • Depend on Kotti >0.7

0.1.1a4 - 2012-07-28

  • Fixed source distribution package.

0.1.1a3 - 2012-07-28

  • Changed class row to row-fluid in contact form template.
  • Added Japanese translation.

0.1.1a2 - 2012-06-28

  • Fixed source distribution package.

0.1.1a1 - 2012-06-27

  • Attachment as optional setting.
  • Added database migration with alembic.

0.1.0b4 - 2012-05-21

  • Changed layout.
  • Added possibility for attachments.

0.1.0b3 - 2012-03-16

  • Update models to use Declarative for compatibility with Kotti >= 0.6.
 
File Type Py Version Uploaded on Size
kotti_contactform-0.3.zip (md5) Source 2013-11-01 161KB
  • Downloads (All Versions):
  • 25 downloads in the last day
  • 275 downloads in the last week
  • 907 downloads in the last month