skip to navigation
skip to content

Not Logged In

psycopg2cffi 0.1

An implementation of the psycopg2 module using cffi.

Latest Version: 2.7.2

An implementation of the psycopg2 module using cffi. The module is currently compatible with Psycopg 2.4.4.

In order to satisfy cffi==0.4 requirement, you currently need to install cffi from source:

pip install -e

To use this package with Django or SQLAlchemy create somewhere in your python path (e.g. the site-packages of your virtual env) a file with the following:

from psycopg2cffi import compat

This will map psycopg2cffi to psycopg2.

This module is only tested with python 2.6+ and PyPy trunk (will be 2.0 release, right now you can get a nighlty build for Linux or OS X from

This is a port of (Michael van Tellingen port of Alex Gaynor’s rpython port ( of psycopg2 to python + ctypes) to cffi.

To run tests, install pytest and run them with:

py.test psycopg2cffi

Submit issues to

  • Downloads (All Versions):
  • 247 downloads in the last day
  • 1118 downloads in the last week
  • 5275 downloads in the last month