skip to navigation
skip to content

pyAMI_atlas 5.0.0-beta7

Python ATLAS Metadata Interface (pyAMI) for ATLAS

Latest Version:

pyAMI 5 is a major upgrade of the AMI python client. The command line syntax has been rationalized, with improved help functions. The code has been split into a core layer and an experiment specific layer. This documentation is specific for the ATLAS layer.

pyAMI is available in the ATLAS software release and also installed centrally on LXPLUS (CVFMS and AFS). pyAMI can be installed standalone on a laptop. Instructions are given below for Linux, OSX and Windows.


All commands are simply subcommands of ami_atlas. On centrally installed versions of pyAMI we have made an alias so that ami is redirected to ami_atlas and the instructions below are for this installation.


The legacy version of pyAMI (pyAMI 4.1.3) is documented here.

A few examples

List runs for 2012 in a period or multiple periods:

ami list runs --year 12 --data-periods A B

List AOD datasets matching a pattern:

ami list datasets --type AOD data14_cos%

Display dataset information:

ami dataset info data13_2p76TeV.00219364.physics_MinBias.merge.NTUP_HI.f519_m1313

Display dataset provenance:

ami dataset prov data13_2p76TeV.00219364.physics_MinBias.merge.NTUP_HI.f519_m1313

List the files in a dataset:

ami list files -LHC data13_2p76TeV.00219364.physics_MinBias.merge.NTUP_HI.f519_m1313


pyAMI also provides an API allowing you to perform all of the same queries from within your own Python program.


pyAMI is installed centrally on LXPLUS at CERN. To begin using pyAMI simply:

export ATLAS_LOCAL_ROOT_BASE=/cvmfs/
localSetupPyAMI pyAMI-5.0.0-beta4

pyAMI is also available through AFS:

source /afs/

Standalone installation

pyAMI 5 is compatible with Python 2.6, 2.7 and 3.X.

Automatic installation for LINUX and MAC OSX


If you have an earlier version of pyAMI installed please uninstall it first: pip uninstall pyAMI

Automatically install the latest version of pyAMI with pip:

pip install --user --pre pyAMI_atlas

or with easy_install:

easy_install --user pyAMI_atlas

Omit the --pre to ignore pre-releases. Omit the --user for a system-wide installation (requires root privileges). Add ${HOME}/.local/bin to your ${PATH} if using --user and if it is not there already (put this in your .bashrc):

export PATH=${HOME}/.local/bin${PATH:+:$PATH}

export PATH=${HOME}/Library/Python/2.7/bin${PATH:+:$PATH}

Execute the post-install script:


To upgrade an existing installation with pip:

pip install --upgrade --pre pyAMI_atlas

or with easy_install:

easy_install --upgrade pyAMI_atlas

Automatic installation for WINDOWS


If you have an earlier version of pyAMI installed please uninstall it first: pip uninstall pyAMI

  1. Install Python 2.7.X

  2. python.exe should be in C:\Python27. You must adjust your paths in the Windows environment. If you do not know how to do this follow the instructions here Add to the path:

  3. Download and install distribute (for easy installation of dependences):

  4. Install pyAMI:

    easy_install pyAMI_atlas
  5. Execute the post-install script:


To upgrade an existing installation:

easy_install --upgrade pyAMI_atlas


VOMS authentication is supported:

voms-proxy-init -voms atlas

If gLite is not available, the alternative option is to connect with your username and password. You can set up an encrypted configuration file by running:

ami auth

You will only need to do this once since your credentials are stored in ~/.pyami/pyami.cfg for later use. If your credentials change just run ami auth again. If you would like to keep your pyAMI configuration in a directory other than ~/.pyami then set the environment variable PYAMI_CONFIG_DIR.

File Type Py Version Uploaded on Size
pyAMI_atlas-5.0.0-beta7.tar.gz (md5) Source 2014-07-03 23KB
  • Downloads (All Versions):
  • 45 downloads in the last day
  • 100 downloads in the last week
  • 436 downloads in the last month