skip to navigation
skip to content

pyosm 0.5.1

Parses OSM XML files in a fast and reliable way.

A Python library for parsing OSM streams.


Assuming Ubuntu 12.04 and an active python virtualenv:

  1. Install build dependencies:

    sudo apt-get install -y build-essential python-dev

  2. Install lxml dependencies:

    sudo apt-get install -y libxml2-dev libxslt-dev

  3. Install requirements:

    pip install -r requirements.txt

  4. Install pyosm:

    python install


There are several examples in the [examples]( directory.

File Type Py Version Uploaded on Size
pyosm-0.5.1.tar.gz (md5) Source 2017-05-31 6KB