skip to navigation
skip to content

pytest-purkinje 0.1.5

py.test plugin for purkinje test runner

pytest-purkinje

py.test plugin for the purkinje test runner. See pukinje test runner on how to get started.

Build Status

Branch Status
dev
master

Coverage:

Supported Python versions

  • Python 2.7.x
  • Python 3.x
  • pypy

Development

Setup

Clone other relevant purkinje-* packages, then:

mkvirtualenv purkinje
workon purkinje
pip install --editable .

ChangeLog

Some minor changes were omitted from this list. For details, see git log.

Release 0.1.5

  • Breaking change: replaced plugin parameter websocket_url with websocket_host and websocket_port. Please update your pytest.ini accordingly if you use non-default settings for purkinje.

Release 0.1.4

2015-03-03

  • Sorted out Travis environment issues

Release 0.1.3

2015-03-02

  • Minor changes

Release 0.1.2

2015-03-01

  • Sorted out Travis environment issues

Release 0.1.1

2015-03-01

  • Loosened version restriction on flotsam lib

Release 0.1.0

2015-03-01

Start of Development

2014-12-11

 
File Type Py Version Uploaded on Size
pytest-purkinje-0.1.5.tar.gz (md5) Source 2015-03-08 10KB