skip to navigation
skip to content

routerchecker 1.1.0

Router firmware update scanner

A Python 3 script for checking router firmware updates.

Installation

Requires Python >=3.2, with 3.5 or later preferred.

To get the latest stable version, install with pip:

$ pip install routerchecker

If you want the latest development version, clone from Git and install with setuptools:

$ git clone https://github.com/thurask/routerchecker.git
$ cd routerchecker
$ python setup.py install

Python Libraries

This library requires the Requests and Beautiful Soup 4 libraries.

License

Copyright 2016 Thurask <thuraski@hotmail.com> This work is free. You can redistribute it and/or modify it under the terms of the Do What The Fuck You Want To Public License, Version 2, as published by Sam Hocevar. See the LICENSE file for more details.

 
File Type Py Version Uploaded on Size
routerchecker-1.1.0-py3-none-any.whl (md5, pgp) Python Wheel 3.5 2016-05-24 5KB
routerchecker-1.1.0.zip (md5, pgp) Source 2016-05-24 7KB