skip to navigation
skip to content

skyscanner 1.1.4

Skyscanner Python SDK

Skyscanner Python SDK for Skyscanner’s API

Features

  • Tested on Python 2.6, 2.7, 3.3, 3.4
  • Supports Flights, Hotels, and Carhire

Installation

At the command line:

$ easy_install skyscanner

Or, if you have virtualenvwrapper installed:

$ mkvirtualenv skyscanner
$ pip install skyscanner

Quick start

  1. Request for an API Key from Skyscanner for Business Contact Page.

  2. Set your API Key:

    from skyscanner.skyscanner import Flights
    flights_service = Flights('<Your API Key>')
    
  3. Get the flights live pricing result by writing a few lines of code:

    from skyscanner.skyscanner import Flights
    
    flights_service = Flights('<Your API Key>')
    result = flights_service.get_result(
        country='UK',
        currency='GBP',
        locale='en-GB',
        originplace='SIN-sky',
        destinationplace='KUL-sky',
        outbounddate='2016-07-28',
        inbounddate='2016-07-31',
        adults=1).parsed
    
    print(result)
    

Note that both the inbounddate and outbounddate might need to be updated.

More examples

For more example usage, refer to our documentation.

Known Issues

  • Tests might appear to be broken sometimes, this is due to the throttling in the API. In such cases, you will see the following error in the build log:

    requests.exceptions.HTTPError: 429 Client Error: Too many requests in the last minute.
    

History

1.0.0 (2015-03-24)

  • First release on PyPI.

1.1.0 (2015-07-18)

  • Stable release on PyPI.

1.1.1 (2015-08-01)

  • Fixes for Python 2.6, 3.3, and 3.4.

1.1.2 (2015-08-01)

  • Support additional params for Flights Pricing Service. Fix for issue #15.

1.1.3 (2015-08-01)

  • Set default error handling to graceful. Fix for issue #19.
 
File Type Py Version Uploaded on Size
skyscanner-1.1.4-py2.py3-none-any.whl (md5) Python Wheel py2.py3 2016-09-12 10KB
skyscanner-1.1.4.tar.gz (md5) Source 2016-09-12 21KB