skip to navigation
skip to content

Not Logged In

squeeze 0.1.7

Bundled HTML/JS/CSS compressor and data-uri embedding tools (YUICompressor, CSSEmbed, DataURI, Google Closure Compiler, HTMLCompressor, Google Closure Stylesheets)

Bundled HTML/CSS/JavaScript minifiers and data-uri embedding tools.

Installation

You need Python and Java installed on your system to be able to use Squeeze. Installing squeeze itself is easy with [pip](http://pypi.python.org/pypi/pip):

$ pip install squeeze

Usage

So you want to use the YUICompressor?

$ squeeze yuicompressor --help

How about the Google Closure Compiler?

$ squeeze closure --help

Ooh. What about CSSEmbed and HTML compressor?

$ squeeze cssembed --help $ squeeze htmlcompressor --help

Whee! More here:

$ squeeze --help

Licensing

Squeeze is released into the public domain. 3rd party libraries included with it, however, carry their own licensing.

Please see the LICENSE file in the source code for more information.

 
File Type Py Version Uploaded on Size
squeeze-0.1.7.tar.gz (md5) Source 2012-03-26 17MB
  • Downloads (All Versions):
  • 24 downloads in the last day
  • 152 downloads in the last week
  • 544 downloads in the last month