skip to navigation
skip to content

udata-gouvfr 1.0.3

uData customizations for Data.gouv.fr

Latest Version: 1.1.0.dev194

uData-gouvfr

uData customizations for Etalab / Data.gouv.fr.

Compatibility

udata-gouvfr requires Python 2.7+ and uData.

Installation

Install uData.

Remain in the same virtual environment (for Python) and use the same version of npm (for JS).

Install udata-gouvfr:

git clone https://github.com/etalab/udata-gouvfr.git
pip install -e udata-gouvfr

Modify your local configuration file of udata (typically, udata.cfg) as following:

PLUGINS = ['gouvfr']
THEME = 'gouvfr'

Build the assets:

inv assets

You can list available development commands with:

inv -l

Changelog

1.0.3 (2017-02-27)

  • Translations update
  • Switch udata-js link to metaclic #161

1.0.2 (2017-02-21)

  • Optimize png images from theme #159
  • Optimize png images sizes for territory placeholders #788

1.0.1 (2017-02-20)

  • Ensure missing FAQ sections raises a 404 #156
  • Provide deep PyPI versions links into the footer #155
  • Provide proper cache versionning for theme assets #155

1.0.0 (2017-02-16)

  • Remove some main menu entries (events, CADA, Etalab)
  • Use a new SVG logo
  • Apply changes from uData 1.0.0

0.9.1 (2017-01-10)

  • First published release
 
File Type Py Version Uploaded on Size
udata_gouvfr-1.0.3-py2.py3-none-any.whl (md5) Python Wheel py2.py3 2017-02-27 4MB