skip to navigation
skip to content

zope.app.http 4.0.1

HTTP Behavior for the Zope Publisher

This package implements the simplest HTTP behavior within the Zope Publisher. It implements all HTTP verbs as views and defines the necessary HTTP exceptions.

CHANGES

4.0.1 (2017-05-16)

  • The PUT views return an empty byte string instead of an empty native string. On Python 3, the unicode native string leads to a TypeError in zope.publisher.http.

4.0.0 (2016-08-08)

  • Added support for Python 3.3 up to 3.6.
  • Added support for PyPy2.

3.10.2 (2011-08-09)

  • Fixing brown bag release 3.10.1, failing tests.

3.10.1 (2011-08-04)

  • Replaced an undeclared test dependency on zope.app.authentication with zope.password.
  • Replaced the testing dependency on zope.app.zcmlfiles with explicit dependencies of a minimal set of packages.

3.10.0 (2011-01-25)

  • PUT raises 405 MethodNotAllowed when the context cannot be adapted to zope.filerepresentation.interfaces.IWriteFile for existing objects resp. zope.filerepresentation.interfaces.IFileFactory for not existing ones.

3.9.0 (2010-09-17)

  • Replaced a testing dependency on zope.app.securitypolicy with one on zope.securitypolicy.
  • Removed test dependency on zope.app.file by moving the test which needs this package to zope.app.file.

3.8 (2010-04-19)

  • Remove dependency on zope.app.testing by using the zope.app.wsgi.testlayer support instead.

    At the time of this writing the test dependency on zope.app.zcmlfiles cannot be removed however, because there is a dependency on zope.app.file for testing, which pulls in the world.

3.7 (2010-04-13)

  • Remove unnecessary dependency on zope.app.publisher.
  • Fix for an edge case: If someone does a defaultView for the context object and someone comes with a not allowed method, the exception view fails on getAdapters.

3.6.1 (2010-01-08)

  • Replaced the dependency on zope.deprecation with BBB imports
  • Made the dependency on zope.app.publisher explicit
  • Fix tests using a newer zope.publisher that requires zope.login.

3.6.0 (2009-05-23)

  • Moved IHTTPException, IMethodNotAllowed, and MethodNotAllowed from zope.app.http to zope.publisher.interfaces.http, fixing dependency cycles involving zope.app.http.

3.5.2 (2009-04-01)

  • Replaced deprecated zope:defaultView directive with browser:defaultView.

3.5.1 (2009-03-12)

  • If the ‘CONTENT_LENGTH’ header is provided, provide this length as argument to the read method of the input stream object.

3.5.0 (2009-02-01)

  • Change dependency on zope.app.container to zope.container.

3.4.5 (2010-01-28)

  • Backport r108613 from trunk: Fix for an edge case: If someone does a defaultView for the context object and someone comes with a not allowed method, the exception view fails on getAdapters.

3.4.4 (2009-01-29)

  • Make tests compatible with new zope.traversing release.

3.4.3 (2009-01-27)

  • Added missing depencendy: zope.app.zcmlfiles.

3.4.2 (2009-01-26)

  • Add a couple of tests to the OPTIONS verb.
  • Substitute zope.app.zapi by direct calls to its wrapped APIs and get rid of zope.app.zapi as a dependency. See bug #LP219302.

3.4.1 (2007-10-31)

  • Resolved ZopeSecurityPolicy deprecation warning.

3.4.0 (2007-10-24)

  • Initial release independent of the main Zope tree.
 
File Type Py Version Uploaded on Size
zope.app.http-4.0.1-py2.py3-none-any.whl (md5) Python Wheel py2.py3 2017-05-16 25KB
zope.app.http-4.0.1.tar.gz (md5) Source 2017-05-16 17KB