skip to navigation
skip to content

Not Logged In

ztfy.jqueryui 0.7.11

A package containing JQuery, JQuery UI, JQuery Tools and a small set of JQuery plugins

What is ztfy.jqueryui ?

ztfy.jqueryui is a set of javascript resources (and their dependencies) allowing any application to easily use a set of JQuery plug-ins; when possible, all CSS and JavaScript resources are already minified via Yahoo 'yui-compressor' tool.

Most of these plug-ins are used by default ZTFY skins and packages.

Currently available plug-ins include :
  • the JQuery engine
  • jquery-alerts
  • jquery-colorpicker
  • jquery-cookie
  • jquery-datatables
  • jquery-datetime
  • jquery-easing
  • jquery-fancybox
  • jquery-form
  • jquery-i18n
  • jqeury-imgareaselect
  • jqeury-jscrollpane
  • jquery-jsonrpc
  • jquery-jtip
  • jquery-layout
  • jquery-liquidcarousel
  • jquery-multiselect
  • jquery-progressbar
  • jquery-tipsy
  • jquery-tools
  • jquery-treetable
  • jquery-ui

How to use ztfy.jqueryui ?

All JQuery resources are just defined as Fanstatic libraries. ZCML registration is not required.

Using a given plug-in is as simple as using the following syntax in any HTML view:

>>> from ztfy.jqueryui import jquery
>>> jquery.need()

Given that, all plug-in dependencies will automatically be included into resulting HTML page.

A single resource can be required several times for a single page, but the resulting resources will be included only one via the Fanstatic machinery.

When available, a minified version as well as a "clear source" version are defined. When using ZTFY.webapp package, the first one is used in "deployment" mode while the second one is automatically used in "development" mode to make debugging very easy.

Requiring plugins through templates

If, for example, you want to call resources from a site's layout for which you don't have any Python class, you can call it directly from a page template, like this:

<tal:var replace="fanstatic:ztfy.jqueryui#jquery" />

The "fanstatic:" expression is provided by ztfy.utils package.

Changelog

0.7.11

  • added JQuery-handsontable plug-in in release 0.10.2

0.7.10

  • updated JQuery-fancybox plug-in to release 1.3.4

0.7.9

  • updated jquery-datetime widget style

0.7.8

  • small CSS and image updates on JQuery-datetime plug-in

0.7.7

  • added overflow on JQuery-multiselect selection box

0.7.6

  • updated JQuery-multiselect plug-in to remove old IE exceptions...

0.7.5

  • added JQuery-color plug-in
  • updated JQuery-multiselect plug-in for backspace key handling
  • update JQuery-tipsy plug-in to take care of tooltip position

0.7.4.1

  • added missing JQuery-masonry resources :-(

0.7.4

  • added JQuery-masonry plug-in

0.7.3

  • JQuery-multiselect plug-in updates to disable highlight and store multiselect instance in input data

0.7.2

  • allow browser cache when loading translations scripts

0.7.1

  • update JQuery to release 1.7.2
  • update JQuery-tools to release 1.2.7
  • add JQuery-mousewheel plug-in
  • small CSS updates

0.7.0

  • added JQuery-1.9.1 and JQuery-migrate plug-in
  • switch default JQuery version to 1.7
  • switch JQuery-form to version 3.27
  • switch JQuery-tools to version 1.2.7
  • added translation string for JQuery-multiselect
  • force background color on JQuery-datetime inputs

0.6.7

  • changed JQuery-layout dependencies

0.6.6

  • added JQuery-dotdotdot plug-in
  • updated JQuery-JScrollPane plug-in
  • dispatch of JQuery-UI plug-ins in several inter-dependent resources

0.6.5

  • added JQuery-tipsy plug-in
  • small CSS updates

0.6.4

  • added JQuery-I18n plug-in
  • updated JQuery-alerts to handle locales
  • updated JQuery-multiselect plug-ins
  • updated locales

0.6.3

  • added JQuery-layout plug-in
  • added JQuery-cookie plug-in
  • added JQuery-liquidcarousel plug-in

0.6.2

  • changed package source layout

0.6.1

  • switched default JQuery-Tools package to release 1.2.4

0.6.0

  • added JQuery ColorPicker plug-in
  • removed unused 'browser' module and moved resources to ztfy.jqueryui

0.5.5

  • new small update on JQuery multi-select widget style
  • updated README.txt

0.5.4

  • small update on JQuery multi-select widget style

0.5.3

  • updated JQuery-MultiSelect plug-in to release 0.1.11-tf
  • improved IE's CSS compatibility for JQuery-MultiSelect plug-in
  • added customized JQuery-ProgressBar plug-in, which is based on Apache2's progress extension module (http://github.com/drogus/apache-upload-progress-module/)

0.5.2

  • updated JQuery UI 1.7 library to release 1.7.3
  • added JQuery UI library in release 1.8.16 (set as default)
  • remove "Tabs" plugin from JQuery UI widgets package to avoid conflict with JQuery Tools Tabs (which is used in several ZTFY packages)
  • remove JQuery-form in releases 2.07 and 2.36
  • remove JQuery-UI in release 1.5.2

0.5.1

  • updated resources path and rebuild minified version of CSS and JS resources

0.5.0

  • migrated from zc.resourcelibrary to zope.fanstatic

0.4.1

  • added JQuery-1.4.4 and JQuery-1.7 ; JQuery-1.4.4 is now the default one for ZTFY packages.

0.4

  • switched to ZTK-1.1.2
  • changed z-index for JQuery datetime calendar to use it in overlays
  • added custom release (0.1.9-tf) of jquery-multiselect plug-in
  • added release 1.7.4 of jquery-datatables plug-in
  • switched jquery-form plugin to release 2.51
  • small style change on date and datetime input fields

0.3

  • added jScrollPane plug-in (revision 93)
  • corrected resources dependencies

0.2

  • added JQuery TOOLS release 1.2.4 (resource 'ztfy.jquery.tools-1.2')
  • removed unused CSS resources

0.1

  • initial release
 
File Type Py Version Uploaded on Size
ztfy.jqueryui-0.7.11-py2.7.egg (md5) Python Egg 2.7 2014-01-31 1MB
ztfy.jqueryui-0.7.11.tar.gz (md5) Source 2014-01-31 1MB
  • Downloads (All Versions):
  • 75 downloads in the last day
  • 929 downloads in the last week
  • 3764 downloads in the last month