skip to navigation
skip to content

Not Logged In

Glances 1.7.3

A cross-platform curses-based monitoring tool

Latest Version: 1.7.6

https://api.flattr.com/button/flattr-badge-large.png https://travis-ci.org/nicolargo/glances.png?branch=master https://badge.fury.io/py/Glances.png https://pypip.in/d/Glances/badge.png

Follow Glances on twitter: glances_system

Glances - An eye on your system

https://raw.github.com/nicolargo/glances/master/docs/images/glances-white-256.png

Glances is a cross-platform curses-based monitoring tool written in Python.

It uses the psutil library to get information from your system.

https://raw.github.com/nicolargo/glances/master/docs/images/screenshot-wide.png

Requirements

  • python >= 2.6 (tested with version 2.6, 2.7, 3.2, 3.3)
  • psutil >= 0.5.1 (recommended version >= 1.2.1)
  • jinja (optional for HTML output)
  • pysensors (optional for HW monitoring support) [Linux-only]
  • hddtemp (optional for HDD temperature monitoring support)
  • batinfo (optional for battery monitoring support) [Linux-only]
  • setuptools

Installation

PyPI: The simple way

Glances is on PyPI. To install, simply use pip:

pip install Glances

To upgrade Glances to the latest version:

pip install --upgrade Glances

Linux

Actually, packages exist for Arch Linux, Fedora/CentOS/RHEL, Debian (Sid/Testing) and Ubuntu (13.04+), so you should be able to install it using your favorite package manager.

FreeBSD

To install the precompiled binary package:

# pkg_add -r py27-glances

To install Glances from ports:

# cd /usr/ports/sysutils/py-glances/
# make install clean

OS X

OS X users can also install Glances using Homebrew or MacPorts.

Homebrew

$ brew install brew-pip
$ export PYTHONPATH=$(brew --prefix)/lib/python2.7/site-packages
$ brew pip Glances

If you get the following error:

Error: Failed executing: pip install glances==X.X --install-option=--prefix=/usr/local/XXX/glances/X.X (.rb:)

Try to run:

$ pip install glances==X.X --install-option=--prefix=/usr/local/XXX/glances/X.X
$ brew link Glances

MacPorts

$ sudo port install glances

Windows

Glances proposes a Windows client based on the colorconsole Python library.

Glances < 1.7.2 only works in server mode. It will run in server mode automatically.

Thanks to Nicolas Bourges, Glances can be easily installed using a Windows installer:

Glances-1.7.2-win32.msi (32-bit, MD5: dba4f6cc9f47b6806ffaeb665c093270)

Otherwise, you have to follow these steps:

Source

To install Glances from source:

$ curl -L https://github.com/nicolargo/glances/archive/vX.X.tar.gz -o glances-X.X.tar.gz
$ tar -zxvf glances-*.tar.gz
$ cd glances-*
# python setup.py install

Note: Python headers are required to install psutil. For example, you need to install first:

  • On Debian/Ubuntu, the python-dev package
  • On CentOS/Fedora, the python-devel package (from the EPEL repository)
  • On openSUSE/SLES/SLED, the python-devel package (from Oss repository)

Puppet

You can install Glances using Puppet: https://github.com/rverchere/puppet-glances

Usage

Just run:

$ glances

and RTFM...

Documentation

For complete documentation see glances-doc.

Author

Nicolas Hennion (@nicolargo) <nicolas@nicolargo.com>

License

LGPL. See COPYING for more details.

 
File Type Py Version Uploaded on Size
Glances-1.7.3.tar.gz (md5) Source 2013-12-15 658KB
  • Downloads (All Versions):
  • 196 downloads in the last day
  • 1103 downloads in the last week
  • 5483 downloads in the last month